本文へスキップ

TIMESELECTOR / USER MANUAL

仕事情報入力画面

この章は旧Windows版の取扱説明書を再構成したものです。画面・機能・提供条件は、今後の月額契約版と異なる場合があります。

取扱説明書の目次を開く
  1. TimeSelectorでできること
  2. 仕事と空き時間の基本
  3. 初めてのスケジューリング
  4. 画面の種類
  5. オートスケジューリング画面
  6. プロジェクト管理画面
  7. 仕事情報入力画面
  8. 空き時間準備画面
  9. スケジュール表示画面
  10. 旧版のエディションとライセンス
  11. 更新とデータの取り扱い

この章の開始・終了の時刻や期間は、自動スケジューリングの配分条件を説明しています。実際の作業や学習の達成を保証するものではありません。条件を満たす時間がない場合は、条件と空き時間を見直してください。

仕事情報入力画面

 仕事情報入力画面は、プロジェクトに仕事情報を登録する時に使用します。

<仕事の追加>
仕事データを追加するには、「追加」ボタンをクリックしてください。基本設定と拡張設定がありますが、最低限の入力に必要な項目は基本設定の「仕事の基本設定」の項目になります。

機能制限:「フリーエディション」は仕事の登録件数に制限があります。プロジェクト毎の仕事の登録件数に制限があるのではなく、プロジェクト全体の仕事の登録件数に制限があります。仕事の登録件数が30件以下でないと、オートスケジューリングを行うことが出来ません。この機能制限はオートスケジューリング時に掛かるため、データの入力やデータの表示は「フリーエディション」でも可能です。

<基本設定の項目>
項目名 項目の内容
仕事ID 新しく、データを追加する場合は、「新規ID」と表示されています。すでに存在するデータを編集した場合は、編集中の「仕事ID」が表示されます。
プロジェクト名 「プロジェクト管理」画面で追加したプロジェクトを選択することが出来ます。仕事を追加したいプロジェクト名を選択してください。
仕事名 仕事名を入力してください。
必要時間 仕事に掛かる時間を入力してください。
必要時間は、実際に取り組める作業単位を目安に設定してください。
細かく分けて登録すると、短い空き時間への配分も検討できます。

-10分、-5分、+5分、+10分のボタンを使用して、素早く必要時間を入力することができます。⇒対応バージョン(ver.1.2.8.0以上)

0分のボタンを使用して、素早く必要時間と完了時間をゼロにすることができます。
⇒対応バージョン(ver.1.3.0.0以上)
完了時間 必要時間に対して、仕事が完了した時間を入力します。
「完了」ボタンを押すと、必要時間と同じになります。また、「未完了」ボタンを押すと、完了時間はゼロ時間になります。
オートスケジューリングする際、すでに完了した時間を考慮してスケジューリングするようになっています。ちょっとでも進んだのであれば、オートスケジューリングする前に、完了した実績を入力するようにしてください。
小さな時間も無駄にしたくないと極限まで考えたときに生まれた機能です。

-10分、-5分、+5分、+10分のボタンを使用して、素早く完了時間を入力することができます。⇒対応バージョン(ver.1.2.8.0以上)

0分のボタンを使用して、素早く完了時間をゼロにすることができます。
⇒対応バージョン(ver.1.3.0.0以上)
メモ 仕事のメモを自由に書くことができます。複数行の入力が可能です。
ここで入力したメモは、「空き時間準備」画面や「スケジュール表示」画面から表示することが出来ます。
必要があれば、仕事の詳細な手順などを書いておくとよいでしょう。


<拡張設定の項目>
項目名 項目の内容
空き時間分類名を指定する。 仕事を割り当てることができる「空き時間分類名」を指定することが出来ます。
指定するには、チェックボックスにチェックを入れ、リストボックスから選択します。
「空き時間分類名」は「分類設定」ボタンから追加することが出来ます。また、設定メニューの「空き時間の分類設定」からも設定が可能です。
「空き時間分類名」を指定しない場合、すべての空き時間が仕事の割り当て対象になります。
仕事のを行う曜日を指定する。 仕事を割り当てることができる曜日を指定することが出来ます。
指定するには、チェックボックスにチェックを入れ、曜日ボタンをクリックしてください。
一括で仕事時間を確保する。 一括指定とよばれる機能です。たとえば、30分を必要とする仕事があるとします。
チェックを入れない場合、分割指定となり、30分間を分割して空き時間に割り当てることになります。すなわち、10分と20分で確保することもあれば、15分と15分で確保することもあります。
チェックを入れた場合、一括指定となり、仕事はきっかりと空き時間に30分間まとめて確保することになります。15分、15分のように分割して空き時間に割り当てられることはありません。

機能制限:一括指定は「スタンダードエディション」では使用できないという機能制限があります。「フリーエディション」と「プロフェッショナルエディション」では使用可能です。一括指定の制限はオートスケジューリング時に掛かるため、データの入力やデータの表示は「スタンダードエディション」でも可能です。
仕事の開始できる条件「次の仕事が事前に終わっていなければならない」 現在入力中の仕事を開始する前に、終わっていなければならない仕事を指定します。指定するにはチェックボックスにチェックを入れ、仕事を選択してください。

一度チェックボックスにチェックを入れておくと、次に仕事を追加するときに、前回追加された仕事が自動的に選択される仕組みになっています。この仕組みを利用することで、データを効率よく入力することが出来ます。

重要(注意事項):プロジェクトの開始条件と仕事の開始条件の指定方法により、開始条件がループする場合があります。開始条件がループすると、条件設定に矛盾が生じ、すべての仕事を空き時間に割り当てできなくなります。開始条件はループしないように設定して下さい。

開始条件がループする例:プロジェクトBの仕事B1はプロジェクトAが終わっていること。かつ、プロジェクトAはプロジェクトBが終わっていること。

<参考までに>
ループの解析には天文学的な計算時間がかかる場合が見つかりました。現在、ループの検出は仕事のみで構成されたループ、または、プロジェクトのみで構成されたループのみの検出となります。

※この重要(注意事項)は下記バージョンにより追加されました。
⇒対応バージョン(ver.1.3.2.0以上)
仕事の開始できる条件「上で選択した仕事が終了した時間から、この仕事を次に指定する期間以降に開始する」 仕事の開始できる条件「次の仕事が事前に終わっていなければならない」で選択した仕事が終了した時間から、現在入力中の仕事が開始できるようになるまでの期間を指定します。
たとえば、17時に問題集を解き、その3時間後以降に再び問題を解いて復習したい場合に使用します。前の仕事の終了から3時間以上あけて開始する、計画上の条件を設定します。
この機能を使用するには、チェックボックスにチェックをいれ、期間を入力してください。

機能制限:復習機能は「スタンダードエディション」では使用できないという機能制限があります。「フリーエディション」と「プロフェッショナルエディション」では使用可能です。復習機能の制限はオートスケジューリング時に掛かるため、データの入力やデータの表示は「スタンダードエディション」でも可能です。
仕事の開始できる条件「上で選択した仕事が終了した時間から、この仕事を次に指定する期間以内に終了する」 仕事の開始できる条件「次の仕事が事前に終わっていなければならない」で選択した仕事が終了した時間から、現在入力中の仕事が終了するまでの期間を指定します。
たとえば、17時に問題集を解き、5時間以内にもう一度問題の復習を行いたい場合に使用します。前の仕事の終了から5時間以内に、現在入力中の仕事を終了する計画上の条件です。
この機能を使用するには、チェックボックスにチェックをいれ、期間を入力してください。

機能制限:復習機能は「スタンダードエディション」では使用できないという機能制限があります。「フリーエディション」と「プロフェッショナルエディション」では使用可能です。復習機能の制限はオートスケジューリング時に掛かるため、データの入力やデータの表示は「スタンダードエディション」でも可能です。

<仕事の編集>
リストから1つの仕事データを選択して、「編集」ボタンを押すと、編集できます。また、リスト上でダブルクリックや、右クリックメニューの「編集」から仕事を編集することが出来ます。

<仕事の削除>
リストから1つまたは、複数の仕事を選択し、「削除」ボタンを押すと、削除できます。右クリックメニューの「削除」からも削除できます。

<プロジェクトに登録されている仕事のみを表示する>
プルダウンメニューから「プロジェクト名」を選択すると、プロジェクトに登録されている仕事のみを表示することが出来ます。また、この状態で仕事の「追加」ボタンを押すと、その選択されたプロジェクトに仕事を追加することが出来ます。
「すべて表示」ボタンを押すと、すべてのプロジェクトの仕事データが表示されます。

<仕事データの印刷>
仕事情報入力画面で「印刷」ボタンを押すと、仕事データの印刷を行うことが出来ます。「印刷プレビュー」ボタンを押すと、印刷イメージが表示されます。ファイルメニューにも「印刷」と「印刷プレビュー」を表示するメニューが用意されています。
プルダウンメニューで「プロジェクト名」を選択し、仕事のデータを絞り込んでいる場合、絞り込まれた仕事のデータのみが印刷対象となります。

<CSV出力>
リスト表示されている仕事データをCSV形式のファイルに出力することが出来ます。ファイルメニューの「CSVファイルに出力」からもデータをCSV出力することが出来ます。
プルダウンメニューで「プロジェクト名」を選択し、仕事のデータを絞り込んでいる場合、絞り込まれた仕事のデータのみがCSV出力対象となります。

<仕事データの コピー/切り取り/貼り付け>
仕事データ単位でコピー、切り取り、貼り付けの操作が可能です。右クリックメニューからも操作を行えます。

<仕事を完了にする>
リストから1つまたは、複数の仕事を選択し、右クリックメニューの「仕事の完了/未完了」から「仕事を完了にする」を選択します。仕事を完了状態にすることができます。

<仕事を未完了にする>

リストから1つまたは、複数の仕事を選択し、右クリックメニューの「仕事の完了/未完了」から「仕事を未完了にする」を選択します。仕事を未完了状態にすることができます。

<仕事の空き時間分類名を変更する>
リストから1つまたは、複数の仕事を選択し、右クリックメニューの「仕事の空き時間分類」から「空き時間分類名を変更する」を選択します。仕事の空き時間分類名を変更することができます。
⇒対応バージョン(ver.1.3.5.3以上)

<仕事の曜日を変更する>
リストから1つまたは、複数の仕事を選択し、右クリックメニューの「仕事の曜日」から「仕事の曜日を変更する」を選択します。仕事の曜日を変更することができます。
⇒対応バージョン(ver.1.3.5.3以上)

<仕事の一括指定/分割指定を変更する>
リストから1つまたは、複数の仕事を選択し、右クリックメニューの「仕事の一括指定/分割指定」から「仕事の時間を一括指定に変更する」、または、「仕事の時間を分割指定に変更する」を選択します。仕事の一括指定/分割指定を変更することができます。
⇒対応バージョン(ver.1.3.5.3以上)

<仕事の復習を追加する>
仕事の復習を簡単に追加することが出来ます。
リストから1つまたは、複数の仕事を選択し、右クリックメニューの「復習」から「仕事の復習を追加する」を選択します。復習する回数を選択し、復習する時期を設定します。
復習は一度に3回分まで追加することが出来ます。
復習する時間の設定も可能です。
復習の回数分、新しいプロジェクトが追加され、そのプロジェクトそれぞれに復習の仕事が追加されます。
よって、複数の仕事のプロジェクトに対して復習を追加することは出来ません。

<リストの順番の並び替えについて>
リストの項目をクリックすると、リストの順番の並び替えが出来ます。

<リストについて>
リストには仕事の一覧が表示されます。
リストの項目 リストの表示内容
ID 仕事のIDが表示されます。
プロジェクト プロジェクトIDとプロジェクト名が表示されます。
仕事 仕事IDと仕事名が表示されます。
必要時間 仕事の必要時間が表示されます。
完了時間 仕事の完了時間が表示されます。
達成度 仕事の達成度が表示されます。
カッコ内は仕事の「必要時間」に対する仕事の「完了時間」の割合がパーセントで表示されています。
開始条件 仕事を開始するために、あらかじめ終わっていなければならない仕事のIDと仕事名が表示されています。
開始条件終了から仕事開始までの期間 「開始条件」の仕事が終わってから、仕事が開始出来るまでの時間が表示されています。
開始条件終了から仕事終了までの期間 「開始条件」の仕事が終わってから、仕事を終了させるまでの時間が表示されています。
曜日指定 仕事が割り当てることが出来る曜日が表示されています。「すべて」と書かれている場合は、すべての曜日を意味します。
空き時間の分類 仕事を割り当てることが出来る「空き時間分類名」が表示されています。
一括指定 仕事の分割指定と一括指定が表示されます。
仕事のメモ 仕事のメモが表示されています。複数行にわたるメモは、続けて1行に表示されます。