TIMESELECTOR / USER MANUAL
空き時間準備画面
この章は旧Windows版の取扱説明書を再構成したものです。画面・機能・提供条件は、今後の月額契約版と異なる場合があります。
取扱説明書の目次を開く
空き時間準備画面
空き時間準備画面は、空き時間を登録する時や、オートスケジューリングのスケジュール結果を表示するときに使用します。
<空き時間の追加>
空き時間データを追加するには、「追加」ボタンをクリックしてください。基本設定と拡張設定がありますが、最低限の入力に必要な項目は基本設定の「空き時間の基本設定」の項目になります。
<基本設定の項目>
<拡張設定の項目>
<空き時間の編集>
リストから1つの空き時間データを選択して、「編集」ボタンを押すと、編集できます。また、リスト上でダブルクリックや、右クリックメニューの「編集」から仕事を編集することが出来ます。編集できる項目は「空き時間分類名」のみとなります。
<空き時間の削除>
リストから1つまたは、複数の空き時間を選択し、「削除」ボタンを押すと、削除できます。右クリックメニューの「削除」からも削除できます。
過去の空き時間の履歴はいつでも削除することが出来ます。仕事の開始条件の仕事が完了してして空き時間の過去の履歴にない場合、空き時間全体のデータより以前に仕事が完了しているものと見なされます。
<空き時間データの印刷>
空き時間準備画面で「印刷」ボタンを押すと、空き時間データの印刷を行うことが出来ます。「印刷プレビュー」ボタンを押すと、印刷イメージが表示されます。ファイルメニューにも「印刷」と「印刷プレビュー」を表示するメニューが用意されています。
<CSV出力>
リスト表示されている空き時間データをCSV形式のファイルに出力することが出来ます。ファイルメニューの「CSVファイルに出力」からもデータをCSV出力することが出来ます。
<仕事を完了にする>
リストから1つまたは、複数の空き時間を選択し、右クリックメニューの「仕事の完了/未完了」から「仕事を完了にする」を選択します。仕事を完了状態にすることができます。ただし、オートスケジューリングでスケジューリングされた予定完了時間のあるデータだけが完了できる対象になります。過去の空き時間データを完了にすることはできません。
<仕事を未完了にする>
リストから1つまたは、複数の空き時間を選択し、右クリックメニューの「仕事の完了/未完了」から「仕事を未完了にする」を選択します。仕事を未完了状態にすることができます。ただし、オートスケジューリングでスケジューリングされた予定完了時間のあるデータだけが未完了できる対象になります。過去の空き時間データを未完了にすることはできません。
<空き時間の空き時間分類名を変更する>
リストから1つまたは、複数の空き時間を選択し、右クリックメニューの「空き時間の空き時間分類」から「空き時間分類名を変更する」を選択します。空き時間の空き時間分類名を変更することができます。
⇒対応バージョン(ver.1.3.5.3以上)
<プロジェクト/仕事のメモを表示する>
プロジェクトの登録時に入力したメモや仕事登録時に入力したメモを表示することが出来ます。右クリックメニューの「メモの表示」を選択してください。メモは編集することもできます。
<リストの順番の並び替えについて>
リストの項目をクリックすると、リストの順番の並び替えが出来ます。
<リストについて>
リストには空き時間の一覧が表示されます。
<空き時間の追加>
空き時間データを追加するには、「追加」ボタンをクリックしてください。基本設定と拡張設定がありますが、最低限の入力に必要な項目は基本設定の「空き時間の基本設定」の項目になります。
<基本設定の項目>
| 項目名 | 項目の内容 |
| 日時 | 空き時間を確保する開始時刻と終了時刻を入力します。 |
| 空き時間の登録方法を選択してください。 | 「単一登録」と「一括登録」があります。 「単一登録」は開始日時から終了日時に登録するという扱いになります。 「一括登録」は開始時間から終了時間の時間帯を開始日から終了日の期間内に登録する扱いになります。 |
| 指定された曜日のみ登録する | 「一括登録」時に利用できる機能です。指定された曜日のみを登録対象とします。 |
<拡張設定の項目>
| 項目名 | 項目の内容 |
| 空き時間を分類する。 | 空き時間に「空き時間分類名」をつけることが出来ます。たとえば、「自宅」にいる時間、「電車」に乗っている通勤/通学の時間を区別しておくことが出来ます。 仕事を登録する際に、「空き時間分類名」を選択することが出来ます。 「自宅」でしかできない仕事は自宅で出来るようにするために作られた機能です。 「場所」という入力項目ではなく、「空き時間分類名」としているのは、他にもいろいろな使い方が出来るからです。 たとえば、この機能を利用して国語の勉強時間、数学の勉強時間、というような時間帯を作ることも可能です。 指定するには、チェックボックスにチェックを入れ、リストボックスから選択します。 「空き時間分類名」は「分類設定」ボタンから追加することが出来ます。また、設定メニューの「空き時間の分類設定」からも設定が可能です。 |
<空き時間の編集>
リストから1つの空き時間データを選択して、「編集」ボタンを押すと、編集できます。また、リスト上でダブルクリックや、右クリックメニューの「編集」から仕事を編集することが出来ます。編集できる項目は「空き時間分類名」のみとなります。
<空き時間の削除>
リストから1つまたは、複数の空き時間を選択し、「削除」ボタンを押すと、削除できます。右クリックメニューの「削除」からも削除できます。
過去の空き時間の履歴はいつでも削除することが出来ます。仕事の開始条件の仕事が完了してして空き時間の過去の履歴にない場合、空き時間全体のデータより以前に仕事が完了しているものと見なされます。
<空き時間データの印刷>
空き時間準備画面で「印刷」ボタンを押すと、空き時間データの印刷を行うことが出来ます。「印刷プレビュー」ボタンを押すと、印刷イメージが表示されます。ファイルメニューにも「印刷」と「印刷プレビュー」を表示するメニューが用意されています。
<CSV出力>
リスト表示されている空き時間データをCSV形式のファイルに出力することが出来ます。ファイルメニューの「CSVファイルに出力」からもデータをCSV出力することが出来ます。
<仕事を完了にする>
リストから1つまたは、複数の空き時間を選択し、右クリックメニューの「仕事の完了/未完了」から「仕事を完了にする」を選択します。仕事を完了状態にすることができます。ただし、オートスケジューリングでスケジューリングされた予定完了時間のあるデータだけが完了できる対象になります。過去の空き時間データを完了にすることはできません。
<仕事を未完了にする>
リストから1つまたは、複数の空き時間を選択し、右クリックメニューの「仕事の完了/未完了」から「仕事を未完了にする」を選択します。仕事を未完了状態にすることができます。ただし、オートスケジューリングでスケジューリングされた予定完了時間のあるデータだけが未完了できる対象になります。過去の空き時間データを未完了にすることはできません。
<空き時間の空き時間分類名を変更する>
リストから1つまたは、複数の空き時間を選択し、右クリックメニューの「空き時間の空き時間分類」から「空き時間分類名を変更する」を選択します。空き時間の空き時間分類名を変更することができます。
⇒対応バージョン(ver.1.3.5.3以上)
<プロジェクト/仕事のメモを表示する>
プロジェクトの登録時に入力したメモや仕事登録時に入力したメモを表示することが出来ます。右クリックメニューの「メモの表示」を選択してください。メモは編集することもできます。
<リストの順番の並び替えについて>
リストの項目をクリックすると、リストの順番の並び替えが出来ます。
<リストについて>
リストには空き時間の一覧が表示されます。
| リストの項目 | リストの表示内容 |
| ID | 空き時間のIDが表示されます。 |
| 開始日時 | 空き時間の開始日時が表示されます。 |
| 終了日時 | 空き時間の終了日時が表示されます。 |
| 期間 | 空き時間の開始日時から終了日時までの期間が表示されます。 |
| プロジェクト | オートスケジューリングによって割り当てられた仕事のプロジェクトIDとプロジェクト名が表示されます。 |
| 仕事 | オートスケジューリングによって割り当てられた仕事の仕事IDと仕事名が表示されます。 |
| 空き時間分類 | 空き時間分類名が表示されます。 |
| 予定完了時間 | オートスケジューリングによって割り当てられた仕事の予定時間の詳細が表示されます。 「分子」は空き時間に割り当てられている仕事の完了時間が表示されています。また、カッコ内は仕事の必要時間と完了時間の割合をパーセントで表示したものです。 「分母」は空き時間に割り当てられている仕事の予定完了時間となります。仕事を分割割り当てしている場合、仕事をどこまで完了させたらよいのか分かりにくいものです。この予定完了時間は分割割り当ての仕事をどこまで終わらせれば完了になるか表示した時間になります。カッコ内は仕事の必要時間と予定完了時間の割合をパーセントで表示したものです。 |