TIMESELECTOR / USER MANUAL
プロジェクト管理画面
この章は旧Windows版の取扱説明書を再構成したものです。画面・機能・提供条件は、今後の月額契約版と異なる場合があります。
取扱説明書の目次を開く
プロジェクト管理画面
プロジェクト管理画面は、仕事のまとまりの単位となるプロジェクトを登録する際に使用します。
<プロジェクトの追加>
プロジェクトデータを追加するには、「追加」ボタンをクリックしてください。基本設定と拡張設定がありますが、最低限の入力に必要な項目は基本設定の「プロジェクトの基本設定」の項目になります。
<基本設定の項目>
<拡張設定の項目>
<プロジェクトの編集>
リストから1つのプロジェクトデータを選択して、「編集」ボタンを押すと、編集できます。また、リスト上でダブルクリックや、右クリックメニューの「編集」からプロジェクトを編集することが出来ます。
<プロジェクトの削除>
リストから1つまたは、複数のプロジェクトを選択し、「削除」ボタンを押すと、削除できます。右クリックメニューの「削除」からも削除できます。
<プロジェクト情報>
リストから1つまたは、複数のプロジェクトを選択し、プロジェクト情報ボタンを押すと、選択されたプロジェクトの集計情報が表示されます。
<プロジェクトデータの印刷>
プロジェクト管理画面で「印刷」ボタンを押すと、プロジェクトデータの印刷を行うことが出来ます。「印刷プレビュー」ボタンを押すと、印刷イメージが表示されます。ファイルメニューにも「印刷」と「印刷プレビュー」を表示するメニューが用意されています。
<CSV出力>
リスト表示されているプロジェクトデータをCSV形式のファイルに出力することが出来ます。ファイルメニューの「CSVファイルに出力」からもデータをCSV出力することが出来ます。
<プロジェクトデータの コピー/切り取り/貼り付け>
プロジェクトデータ単位でコピー、切り取り、貼り付けの操作が可能です。右クリックメニューからも操作を行えます。
<プロジェクトを完了にする>
リストから1つまたは、複数のプロジェクトを選択し、右クリックメニューの「プロジェクトの完了/未完了」から「プロジェクトを完了にする」を選択します。プロジェクトに登録されているすべての仕事が完了状態になります。
<プロジェクトを未完了にする>
リストから1つまたは、複数のプロジェクトを選択し、右クリックメニューの「プロジェクトの完了/未完了」から「プロジェクトを未完了にする」を選択します。プロジェクトに登録されているすべての仕事が未完了状態になります。
<プロジェクトの開始日/完了日を早めたり、遅くしたりする>
リストから1つまたは、複数のプロジェクトを選択し、右クリックメニューの「プロジェクトの開始日/期限日」からそれぞれメニューを選択します。プロジェクトの開始日/期限日を1日間、1週間、1ヶ月間単位で早めたり、遅くしたりできます。プロジェクトの開始日については、プロジェクトの開始日が指定されているときのみ早めたり、遅くしたりする機能が有効となります。
⇒対応バージョン(ver.1.3.4.0以上)
<リストの順番の並び替えについて>
リストの項目をクリックすると、リストの順番の並び替えが出来ます。
<リストについて>
リストにはプロジェクトの一覧が表示されます。
<プロジェクトの追加>
プロジェクトデータを追加するには、「追加」ボタンをクリックしてください。基本設定と拡張設定がありますが、最低限の入力に必要な項目は基本設定の「プロジェクトの基本設定」の項目になります。
<基本設定の項目>
| 項目名 | 項目の内容 |
| プロジェクトID | 新しく、データを追加する場合は、「新規ID」と表示されています。すでに存在するデータを編集した場合は、編集中の「プロジェクトID」が表示されます。 |
| 期限日 | プロジェクトの期限の日時を入力してください。登録した仕事を期限日時までに配分する、計画上の条件になります。実際の仕事の完了を保証するものではありません。 |
| プロジェクト名 | 仕事のまとまりとなるプロジェクト名を入力してください。 |
| メモ | プロジェクトのメモを自由に書くことができます。複数行の入力が可能です。 ここで入力したメモは、「空き時間準備」画面や「スケジュール表示」画面から表示することが出来ます。 |
<拡張設定の項目>
| 項目名 | 項目の内容 |
| プロジェクトの開始日時を指定する | 必要があれば、チェックボックスを有効にし、プロジェクトを開始したい日時を入力してください。登録した仕事を、指定した開始日時以降に配分する条件になります。 |
| プロジェクトの開始できる条件 | 必要があれば、チェックボックスを有効にし、プロジェクトの開始できる条件を指定することができます。 ここで選択したプロジェクトがすべて終わらなければ、すなわち、ここで選択したプロジェクトの仕事がすべて終わらなければ現在入力中のプロジェクトを開始できなくなります。 重要(注意事項):プロジェクトの開始条件と仕事の開始条件の指定方法により、開始条件がループする場合があります。開始条件がループすると、条件設定に矛盾が生じ、すべての仕事を空き時間に割り当てできなくなります。開始条件はループしないように設定して下さい。 開始条件がループする例:プロジェクトBの仕事B1はプロジェクトAが終わっていること。かつ、プロジェクトAはプロジェクトBが終わっていること。 <参考までに> ループの解析には天文学的な計算時間がかかる場合が見つかりました。現在、ループの検出は仕事のみで構成されたループ、または、プロジェクトのみで構成されたループのみの検出となります。 ⇒対応バージョン(ver.1.3.2.0以上) |
| 進行倍率 | プロジェクトが複数ある場合に、複数のプロジェクトの仕事が進むようにスケジューリングされます。 その際に、切り替え時間を1つの目安にしてプロジェクトの仕事を切り替えます。 タイムセレクタでは、基本的に期限日優先で仕事を割り当てていきます。期限日が同じプロジェクトを割り当てる場合、プロジェクトの切り替え時間で割り当てを行っていきますが、同じ期限日でも仕事の進み方を早めたい場合があります。そのような時に、進行倍率を大きくするとプロジェクトの進み方が早くなります。 ただし、人工知能エンジンはプロジェクトの完了率が低いものを優先したり、様々な仕事の条件を守ろうとしますので、必ずしもユーザの進行倍率の要求が満たされるものではないことに注意が必要です。 |
| 期限日最優先のプロジェクトと並行して進める。 | 人工知能エンジンはプロジェクトの期限日の順番に仕事を割り当てていきます。その為、期限日の遅い仕事がなかなかできないスケジュールとなってしまいがちです。期限日が遅くても、ちょっとずつプロジェクトの仕事を進めておきたい場合の、チェックを入れてください。 |
<プロジェクトの編集>
リストから1つのプロジェクトデータを選択して、「編集」ボタンを押すと、編集できます。また、リスト上でダブルクリックや、右クリックメニューの「編集」からプロジェクトを編集することが出来ます。
<プロジェクトの削除>
リストから1つまたは、複数のプロジェクトを選択し、「削除」ボタンを押すと、削除できます。右クリックメニューの「削除」からも削除できます。
<プロジェクト情報>
リストから1つまたは、複数のプロジェクトを選択し、プロジェクト情報ボタンを押すと、選択されたプロジェクトの集計情報が表示されます。
<プロジェクトデータの印刷>
プロジェクト管理画面で「印刷」ボタンを押すと、プロジェクトデータの印刷を行うことが出来ます。「印刷プレビュー」ボタンを押すと、印刷イメージが表示されます。ファイルメニューにも「印刷」と「印刷プレビュー」を表示するメニューが用意されています。
<CSV出力>
リスト表示されているプロジェクトデータをCSV形式のファイルに出力することが出来ます。ファイルメニューの「CSVファイルに出力」からもデータをCSV出力することが出来ます。
<プロジェクトデータの コピー/切り取り/貼り付け>
プロジェクトデータ単位でコピー、切り取り、貼り付けの操作が可能です。右クリックメニューからも操作を行えます。
<プロジェクトを完了にする>
リストから1つまたは、複数のプロジェクトを選択し、右クリックメニューの「プロジェクトの完了/未完了」から「プロジェクトを完了にする」を選択します。プロジェクトに登録されているすべての仕事が完了状態になります。
<プロジェクトを未完了にする>
リストから1つまたは、複数のプロジェクトを選択し、右クリックメニューの「プロジェクトの完了/未完了」から「プロジェクトを未完了にする」を選択します。プロジェクトに登録されているすべての仕事が未完了状態になります。
<プロジェクトの開始日/完了日を早めたり、遅くしたりする>
リストから1つまたは、複数のプロジェクトを選択し、右クリックメニューの「プロジェクトの開始日/期限日」からそれぞれメニューを選択します。プロジェクトの開始日/期限日を1日間、1週間、1ヶ月間単位で早めたり、遅くしたりできます。プロジェクトの開始日については、プロジェクトの開始日が指定されているときのみ早めたり、遅くしたりする機能が有効となります。
⇒対応バージョン(ver.1.3.4.0以上)
<リストの順番の並び替えについて>
リストの項目をクリックすると、リストの順番の並び替えが出来ます。
<リストについて>
リストにはプロジェクトの一覧が表示されます。
| リストの項目 | リストの表示内容 |
| ID | プロジェクトのIDが表示されます。 |
| プロジェクト名 | プロジェクト名が表示されます。 |
| 開始日時指定 | 開始日時の指定がある場合は、開始日時が表示されます。指定がない場合には、「開始日時指定なし」が表示されます。 |
| 期限日時 | 期限日時が表示されます。 |
| 完了予定日 | 空き時間に割り当てられていない仕事がある場合、「未割り当ての仕事があります。」と表示されます。 オートスケジューリングを行い、すべてのプロジェクトの仕事が空き時間に割り当てられているとき、プロジェクトの仕事が完了する日時が表示されます。 |
| 余裕日時 | 完了予定日と期限日時の差が期間で表示されます。 |
| 進行倍率 | プロジェクトの進行倍率が表示されます。 |
| プロジェクトの必要時間 | プロジェクトの仕事の必要時間を合計した時間が表示されます。 |
| 完了率 | プロジェクトの仕事の必要時間の合計とプロジェクトの仕事の完了時間の合計の割合をパーセントで表示したものが表示されます。 |
| 並行作業 | 期限日最優先のプロジェクトと並行して進めるかどうか表示されます。 |
| プロジェクトのメモ | プロジェクトのメモが表示されます。複数行は1行となって表示されます。 |